WordPress博客搬家后更改新域名使得网站正常运行

WordPress网站在更换域名后,需要重新配置当前域名才能使得网站正常运行,很多人遇到过这样的情况,那么如何解决呢,本文将介绍几种方法供你选择

最简单、先配置后导出:

在旧域名下登陆博客的设置界面,“设置-> 常规 ”里重新配置新域名,然后将数据库导出,这样网站搬家后,连接数据库即可使得网站正常运行。

  (更多…)

Read More

无需升级_您的WordPress数据库已经是最新的了!

解决WordPress”无需升级 您的WordPress数据库已经是最新的了!”无法登陆后台

解决办法:

今天登陆博客发现无法登陆后台,屏幕上出现两句话:

无需升级

您的WordPress数据库已经是最新的了!

 

点击继续后会跳转到博客首页,就一直这样反复。

但是我近期也没有更新Wordpress,也没有更改博客设置,不知道是怎么出现的这种情况,各种尝试都无法登陆后台后,上网查找了解决方案,方案中的办法是安装一个插件,但是我安装这个插件后无法启用,一看这个插件是3年前更新的,已经没法使用了。

进入后台的办法是将 /wp-content/object-cache.php 文件重命名为 object-cache.php.bak,这时就可以登陆博客后台了,安装 WP Memcached Manager 插件,然后 flush memcache 下,再把刚刚重命名文件改回去,如果可以启用这个插件的话,就可以愉快的继续使用缓存了,不然就只能收到清空缓存了。

后来找 到可能的原因是由于缓存的问题导致无法登陆后台,因为我的博客启用了阿里云的缓存OSC,既然要清空缓存那就登陆阿里云的控制台,找到OSC控制台,点击“清空实例缓存”。

果然,清空实例缓存后就可以登陆 WordPress博客后台了。

 

总结:

方法一:

重命名/wp-content/object-cache.php为任何后缀文件

重新登录后台,安装 WP Memcached Manager 插件,然后 flush memcache 下,再把刚刚重命名文件改回去

然后就可以愉快的继续使用缓存了。

方法二:

登陆阿里云的控制台,找到OSC控制台,点击“清空实例缓存”。

 

 

Read More

云并不能够做到100%可靠

说下今天遇到的故障吧,网站的一个磁盘容量不足了,我就想把磁盘的容量扩大。他们提供磁盘扩容功能的,只要在控制面板的磁盘界面,选择要扩容的磁盘,确认要升级的容量以及价格。我在顺利完成付款后,提示要重启后才能看到扩容,好吧,重启了。但在重启后发现虽然控制界面的磁盘容量是变了,但还要自己登陆服务器区扩容,将原来的分区扩大。
找了好久才找到关于扩容的教程,按照教程一步步地走,遇到了问题,提示是这样的:
[root@iZ2811v ~]# e2fsck -f /dev/xvdc1
e2fsck 1.41.12 (17-May-2010)
e2fsck: 超级块无效, trying backup blocks...
e2fsck: Bad magic number in super-block 当尝试打开 /dev/xvdc1 时

The 超级块 could not be read or does not describe a correct ext2
文件系统. If the 设备 is valid and it really contains an ext2
文件系统 (and not swap or ufs or something else), then the 超级块
is corrupt, and you might try running e2fsck with an alternate 超级块:
e2fsck -b 8193 <设备>


然后试了好多次,开始以为是我的操作出问题了,但我就是按照教程一步步来的,还自己上网查了,好多次仍然是这样,实在没办法只好提交工单,请他们的工程师帮忙。

(更多…)

Read More

域名已经使用一年啦

今天距离域名到期还有6天的时间了,猛然间,lxx1.com 已经使用了1年的时间,但是回想起刚刚注册这个域名的场景还历历在目,现在lxx1.com 已经有好几个网站了,包括现在的这个博客网站,总算没有闲置,也是发挥出了自己应有的作用。
刚刚又续费一年了,虽然想放弃这个域名,但是不管怎样,这个域名暂时还是会保留下去的(主要是因为备案太麻烦了!!)。

(更多…)

Read More

博客升级到WordPress4.2.2中文版

今天将博客升级到了Wordpress4.2.2中文版,由于在wordpress此前版本的默认主题中包含了一个ico图标生成文件(genericons)功能,导致受到了安全影响,目前官方已经修复此漏洞(从日志看是删除了主题中带的genericons/example.html文件)。同时修复的还有上次发现的一个跨站安全漏洞。此外该版本还修复了编辑器可视化下的一个跨站攻击漏洞以及其他兼容性问题。

(更多…)

Read More